新手树莓派4b连接无屏幕连接ssh问题

小水杯 20cm2020-02-12120 次点击1 人感谢

手里没有可以连接树莓派的屏幕,只能无屏幕安装,看了网上的教程,烧录好了raspbian系统,在SD卡上的boot文件下添加了一个空的ssh文件和一个wpa_supplicant.conf文件,里面的配置信息如下:
country=CN
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
 
network={‌
ssid="TP-LINK_A0D2“
psk="12345678"
key_mgmt=WPA-PSK
priority=1
}
看网上的教程说这样树莓派就可以自动连接上wifi了,但是我在路由器的设置界面中并没有发现有树莓派连接上去,ssh也没办法使用,后续的配置也没办法弄。
小白请各位路过的大神帮帮忙,感激不尽。

收藏 ♥ 感谢
Spoony 小组长 2020-02-12 
我看到有个引号输错了,你检查下
小水杯 20cm 2020-02-12 
@Spoony 改过了,还是没有用
Spoony 小组长 2020-02-12 
@小水杯 除了那个输入错误暂时没发现其他问题。
建议:
1、确认一下这个系统之前没有连接过任何wifi,这种配置方法仅适用于首次连接wifi使用
2、wifi口令无误、key_mgmt 配置无误

无法给到更多建议。
RaspiSQH 34.7m 2020-02-13 
我以前也试过这种方法,完全没用。。。。建议拿网线连一次配置好再用无线。还有时候是路由器有问题,我就有一个路由器,不认树莓派,无论有线无线,管理界面不显示,树莓派上却显示已连接,不过实际上不能用。。。。
小水杯 20cm 2020-02-13 
@RaspiSQH 多谢,已经用有线直连路由器成功了,在路由器管理界面显示出了树莓派。
不过想用无线连接,使用sudo nano /etc/wpa_supplicant/wpa_supplicant.conf配置了wifi信息,拔下网线,重启,还是没用,现在就只能有线连接路由器使用网络。请问你是怎么成功配置无线的啊
Spoony 小组长 2020-02-13 
@小水杯 配置参考

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
auto wlan0

iface wlan0 inet dhcp
wpa-ssid "ssid"
wpa-psk "password"

https://shumeipai.nxez.com/2014/08/03/adafruit-raspberry-faction-tutorial-network-settings.html
RaspiSQH 34.7m 2020-02-13  ♥ 1
@小水杯 直接打开vnc登录桌面,然后在gui界面配置即可,我曾经就是这么搞的。
注意开启无线后不要直接拔掉电源,还有接线时小心,不要短路3v3和5v或者把金属掉在排针上,很危险。
小水杯 20cm 2020-02-13  ♥ 1
@RaspiSQH 多谢,经过一天的努力已经解决,试了网上的的一些该文件的方法并没用,我用的是20-02-05版的raspbian,换了19-7-10版的raspbian已可以正常显示Wi-Fi了

登录注册 后可回复。




› 相关内容关注微信公众号