远程连接windows失败 已重新安装tightvncsever xrdp 数据源为清华tuna源

hegee 10cm2020-01-2544 次点击

删除系统自带tightvnc xrdp时
pi@raspberrypi:~ $ sudo apt-get purge tightvnc xrdp
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package tightvnc

可重新安装tightvncsever xrdp
pi@raspberrypi:~ $ sudo apt-get install tightvncserver xrdp
Reading package lists... Done
Building dependency tree
Reading state information... Done
tightvncserver is already the newest version (1:1.3.9-9).
xrdp is already the newest version (0.9.1-9+deb9u3).
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.


pi@raspberrypi:~ $ sudo apt upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libqscintilla2-qt5-l10n : Breaks: libqt5scintilla2-l10n (< 2.10) but 2.9.3+dfsg-4 is to be installed
E: Broken packages


与windows桌面连接时出现如下错误
Connection Log

connecting to sesman ip 127.0.0.1 port 3350
sesman connection ok
sending login info to session manager,please wait...
login successful for display 10
started connecting
connection problem,give up
some problem

收藏 ♥ 感谢
Spoony 小组长 2020-01-25 
试试如下解决方法

第一步:
sudo apt-get install xserver-xorg-core
sudo apt-get -y install xserver-xorg-input-all

第二步,安装XRDP
sudo apt-get install xrdp

第三步:
sudo apt-get install xorgxrdp

https://c-nergy.be/blog/?p=13390
hegee 10cm 2020-01-26 
按照链接中所给步骤操作,下载xorgxrdp时显示问题为未下载xorg
下载xorg后再下载xorgxrdp仍然不成功,且远程连接问题如常

pi@raspberrypi:~ $ sudo apt-get install xorgxrdp
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
xorgxrdp : Depends: xorg-video-abi-23
Recommends: xorg but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

pi@raspberrypi:~ $ sudo apt-get install xorg
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
x11-apps x11-session-utils xbitmaps xfonts-75dpi xfonts-scalable
xorg-docs-core
Suggested packages:
mesa-utils xorg-docs x11-xfs-utils
The following NEW packages will be installed:
x11-apps x11-session-utils xbitmaps xfonts-75dpi xfonts-scalable xorg
xorg-docs-core
0 upgraded, 7 newly installed, 0 to remove and 1 not upgraded.
Need to get 4,431 kB of archives.
After this operation, 6,637 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://mirrors.tuna.tsinghua.edu.cn/raspbian/raspbian stretch/main armhf x 11-apps armhf 7.7+6 [544 kB]
Get:2 http://mirrors.tuna.tsinghua.edu.cn/raspbian/raspbian stretch/main armhf x 11-session-utils armhf 7.7+2 [61.4 kB]
Get:3 http://mirrors.tuna.tsinghua.edu.cn/raspbian/raspbian stretch/main armhf x bitmaps all 1.1.1-2 [32.1 kB]
Get:4 http://mirrors.tuna.tsinghua.edu.cn/raspbian/raspbian stretch/main armhf x fonts-75dpi all 1:1.0.4+nmu1 [3,367 kB]
Get:5 http://mirrors.tuna.tsinghua.edu.cn/raspbian/raspbian stretch/main armhf x fonts-scalable all 1:1.0.3-1.1 [304 kB]
Get:6 http://mirrors.tuna.tsinghua.edu.cn/raspbian/raspbian stretch/main armhf x org-docs-core all 1:1.7.1-1 [83.8 kB]
Get:7 http://mirrors.tuna.tsinghua.edu.cn/raspbian/raspbian stretch/main armhf x org armhf 1:7.7+19 [38.4 kB]
Fetched 4,431 kB in 4s (991 kB/s)
Selecting previously unselected package x11-apps.
(Reading database ... 156319 files and directories currently installed.)
Preparing to unpack .../0-x11-apps_7.7+6_armhf.deb ...
Unpacking x11-apps (7.7+6) ...
Selecting previously unselected package x11-session-utils.
Preparing to unpack .../1-x11-session-utils_7.7+2_armhf.deb ...
Unpacking x11-session-utils (7.7+2) ...
Selecting previously unselected package xbitmaps.
Preparing to unpack .../2-xbitmaps_1.1.1-2_all.deb ...
Unpacking xbitmaps (1.1.1-2) ...
Selecting previously unselected package xfonts-75dpi.
Preparing to unpack .../3-xfonts-75dpi_1%3a1.0.4+nmu1_all.deb ...
Unpacking xfonts-75dpi (1:1.0.4+nmu1) ...
Selecting previously unselected package xfonts-scalable.
Preparing to unpack .../4-xfonts-scalable_1%3a1.0.3-1.1_all.deb ...
Unpacking xfonts-scalable (1:1.0.3-1.1) ...
Selecting previously unselected package xorg-docs-core.
Preparing to unpack .../5-xorg-docs-core_1%3a1.7.1-1_all.deb ...
Unpacking xorg-docs-core (1:1.7.1-1) ...
Selecting previously unselected package xorg.
Preparing to unpack .../6-xorg_1%3a7.7+19_armhf.deb ...
Unpacking xorg (1:7.7+19) ...
Setting up x11-apps (7.7+6) ...
Setting up xorg-docs-core (1:1.7.1-1) ...
Setting up x11-session-utils (7.7+2) ...
Setting up xfonts-75dpi (1:1.0.4+nmu1) ...
Setting up xbitmaps (1.1.1-2) ...
Setting up xfonts-scalable (1:1.0.3-1.1) ...
Setting up xorg (1:7.7+19) ...
Processing triggers for man-db (2.8.5-2) ...
Processing triggers for fontconfig (2.13.1-2) ...
pi@raspberrypi:~ $ ^C
pi@raspberrypi:~ $ sudo apt-get install xorgxrdp
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
xorgxrdp : Depends: xorg-video-abi-23
E: Unable to correct problems, you have held broken packages.
hegee 10cm 2020-01-26 
然后我查了一下xorg-video-abi-23
显示有
dep: xorg-video-abi-23
本虚包由这些包填实: xserver-xorg-core, xserver-xorg-core-udeb
在下载xserver-xorg-core-udeb 时
pi@raspberrypi:~ $ sudo apt-get install xserver-xorg-core-udeb
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package xserver-xorg-core-udeb
请问这样要怎么办呢?

@Spoony
hegee 10cm 2020-01-26  ♥ 1
问题已解决
是数据源的debian版本的问题

登录注册 后可回复。

这里由以下店铺的技术人员在此免费提供能力范围内的技术支持。

NXEZ 创客商店(淘宝)

排障问题发帖注意事项:
1、请尽可能将故障说明清晰,列明例如使用环境和做了哪些操作和配置等。
2、排障中已经做了哪些尝试,如果能在问题中进行描述将极大提高解决问题的效率。
3、对于需要自身完成知识积累才能解决的问题,请自行通过搜索引擎寻找资料学习。