安装pycharm时提示:错误: 加载主类 com.intellij.idea.Main 时出现 LinkageError

Txan 10cm2023-08-091415 次点击
树莓派4B 系统是Linux raspberrypi 5.15.76

报错提示:错误: 加载主类 com.intellij.idea.Main 时出现 LinkageError

检查过了 只有一个jdk版本 java-11-openjdk-arm64 环境变量也正确配置了 就是安装不了 一开安装的pycharm.sh就报错
收藏 ♥ 感谢
Txan 10cm 2023-08-09 
pi@raspberrypi:~/Desktop/pycharm-2023.2/bin $ ./pycharm.sh
CompileCommand: exclude com/intellij/openapi/vfs/impl/FilePartNodeRoot.trieDescend
错误: 加载主类 com.intellij.idea.Main 时出现 LinkageError
java.lang.UnsupportedClassVersionError: com/intellij/idea/Main has been compiled by a more recent version of the Java Runtime (class file version 61.0), this version of the Java Runtime only recognizes class file versions up to 55.0
Spoony 小组长 2023-08-09 
错误信息看就是 java Runtime 版本太低。要安装 61.0 的 Runtime。
sorrya0 30cm 2023-08-09  ♥ 1
错误信息表明您正在运行旧版本的Java运行时环境(JRE),该JRE与IntelliJ IDEA Main类的类文件版本不兼容。要解决此问题,您有几个选项:将Java运行时环境升级到支持类文件版本61.0的新版本。您可以从Oracle官方网站下载最新版本的Java。如果您已经安装了最新版本的Java,但仍然遇到此问题,则可能是您的IntelliJ IDEA安装使用了不同版本的Java。在这种情况下,
Txan 10cm 2023-11-08 
@Spoony 感谢小组长~
Txan 10cm 2023-11-08 
@sorrya0 谢谢sorrya0同学 解决了我的问题~

登录注册 后可回复。




› 相关内容关注微信公众号