树莓派安装pandas和sklearn都出现了这样的问题,能帮忙一起讨论一下吗

lu的raspi 35cm2022-08-26123 次点击
pi@raspberrypi:~ $ sudo apt-get install python3-pandas
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
python3-pandas-lib : 依赖: python3 (< 3.8) 但是 3.9.2-3 正要被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。
收藏 ♥ 感谢
oxygen 1.1m 2022-08-26  ♥ 1
试一试
sudo update,或者sudo upgrade
我就是这样装那些依赖关系不够的库
mep 90cm 2022-08-29  ♥ 1
试试用virtual env建立虚拟python环境来安装python包
或者试着将包安装在用户目录下pip install pandas --user
或者安装的系统目录中 sudo pip install pandas

登录注册 后可回复。




› 相关内容关注微信公众号